TegraOwners a500 Repository

Linux development for the Acer A500/A501

Re: TegraOwners a500 Repository

Postby romez27 » 21 Mar 2015, 23:33

anyway to copy pasre with onboard..cheers
A500 on skrillax v9 bootloader
4.4.4 tegraowners rom v22
User avatar
romez27
Senior Owner
 
Posts: 239
Joined: 08 May 2012, 13:44
Reputation point: 23
Junior Owner

Re: TegraOwners a500 Repository

Postby romez27 » 23 Mar 2015, 20:58

rickdtweet » 07 Mar 2015, 20:36 wrote:Will take drivers, thanks :)

i typed first command in terminal and scrolled to bottom ,but saw nothing that says nvidia
A500 on skrillax v9 bootloader
4.4.4 tegraowners rom v22
User avatar
romez27
Senior Owner
 
Posts: 239
Joined: 08 May 2012, 13:44
Reputation point: 23
Junior Owner

Re: TegraOwners a500 Repository

Postby thor2002ro » 23 Mar 2015, 21:13

romez27 » 23 Mar 2015, 20:58 wrote:
rickdtweet » 07 Mar 2015, 20:36 wrote:Will take drivers, thanks :)

i typed first command in terminal and scrolled to bottom ,but saw nothing that says nvidia

should look like this

Code: Select all
Package: nvidia-tegra
Pin: release n=raring
Pin-Priority: 5000


its 100% there
_________________________
Dropbox! So useful for sharing files among multiple computers and ANDROID Phone get 2.30GB storage -> LINK

++++++++++++
Samsung Galaxy Note - Drowned

Samsung Galaxy Note 2 - Sold

Oppo R5s - Sold

LG V10 :)

Acer ICONIA A500 TAB WIFI Only
FW: Tegraowners 6.0 internal ROM
Recovery: touch recovery 2.0b

Asus Google Nexus 7 Wifi
FW: Tegraowners JB-MR2 ROM
++++++++++++
If I did something you liked HIT rep + button (: and Image $Image to BEER FUND
User avatar
thor2002ro
Global moderator / Dev Team
 
Posts: 10042
Joined: 14 Aug 2011, 23:31
Location: 127.0.0.1
Reputation point: 594
Junior OwnerJunior OwnerJunior OwnerJunior OwnerJunior OwnerJunior Owner

Re: TegraOwners a500 Repository

Postby romez27 » 24 Mar 2015, 00:32

ok found it just didnt know how to scroll down .had to use arrow on onboard..cheers mate
A500 on skrillax v9 bootloader
4.4.4 tegraowners rom v22
User avatar
romez27
Senior Owner
 
Posts: 239
Joined: 08 May 2012, 13:44
Reputation point: 23
Junior Owner

Re: TegraOwners a500 Repository

Postby Are G. Bee » 10 Apr 2015, 05:41

Hey, just a question to help clarify compatibility with 14.04 & MATE.

I am currently on 14.04 and I installed MATE as per the instructions. The installation appeared to go just fine but upon restarting I have lost the ability to use the OnBoard keyboard on the Lock & Login screens. I am able to pull up the keyboard, which displays and presses just fine, but the actual button presses do nothing except for the TAB button, which works just fine? One thing to note is that if I plug in a keyboard and log on, then OnBoard seems to kick back in and functions just fine?

Prior to installing MATE, OnBoard was functioning just fine. I have also tried adjusting the accessibility options as per some suggestions I have found online but nothing seems to work...So I guess I'd like to just clarify whether MATE is also compatible with 14.04?

Any suggestions would be greatly appreciated, and please bare in mind that I am new to linux so please be kind :)
User avatar
Are G. Bee
Junior Owner
 
Posts: 4
Joined: 20 Jan 2012, 17:45
Reputation point: 0
Junior Owner

Re: TegraOwners a500 Repository

Postby rickdtweet » 10 Apr 2015, 08:25

There's a problem with all virtual keyboards apparently, so the solution is: press really fast the key on the onboard keyboard and also really fast on the password field ...and it inputs :)
User avatar
rickdtweet
Testers Group
 
Posts: 842
Joined: 16 Sep 2013, 16:48
Reputation point: 38
Junior Owner

Re: TegraOwners a500 Repository

Postby Are G. Bee » 10 Apr 2015, 22:32

rickdtweet » 10 Apr 2015, 01:25 wrote:There's a problem with all virtual keyboards apparently, so the solution is: press really fast the key on the onboard keyboard and also really fast on the password field ...and it inputs :)



Thanks for your quick reply, and I can say that your suggestion does work!...ish :P

Some characters seem to respond to it, others are to tricky to position my big fingers...The keyboard is also quite tiny and appears to be non-adjustable on the login screen. After an hour of trying I still couldn't not enter in my password correctly! :( (In all fairness my passwords are a bit complicated so I can't see this method working for me)

I too have found a lot of info regarding bugs/issue with OnBoard and the Login screen, but most of those issues did not quite match this one. They usually refer to not being able to load up OnBoard, or what does come up is blank panel, but in this case everything worked fine until I restarted after the MATE install? It just seems too specific to fit into those general bug issues those posts are referring to? I can also state that I have tested this with three fresh installs and they all run into this issue directly after installing MATE so I would assume it must be related?

Couple Q's:

Does anyone know of an easy way to revert back to before I installed MATE? I am not too familiar with Ubuntu to know if an uninstall would be enough to put the previous settings back?

Does MATE adjust the OnBoard settings during it's install? If so, can anyone suggest which files I should look at...like keymap files, or any other configs that bind the keys?

As the TAB & ARROW buttons on OnBoard still work flawlessly, is it possible that the key mappings have been reset and only a few select keys are still properly mapped? The fact that they are working properly somewhat suggests the keyboard can work fine, but it seems like the rest of the keys are just unmapped so it just does nothing?


Thanks again for any help you can provide!
User avatar
Are G. Bee
Junior Owner
 
Posts: 4
Joined: 20 Jan 2012, 17:45
Reputation point: 0
Junior Owner

Re: TegraOwners a500 Repository

Postby thor2002ro » 10 Apr 2015, 23:42

I cant think of an easy way to get back before... apart from looking at logs and identify the new packages.... or reinstall ubuntu...
but mate and login program are 2 different things... one is not related to the other.... learn how to manipulate apt and you can install many things and versions...
_________________________
Dropbox! So useful for sharing files among multiple computers and ANDROID Phone get 2.30GB storage -> LINK

++++++++++++
Samsung Galaxy Note - Drowned

Samsung Galaxy Note 2 - Sold

Oppo R5s - Sold

LG V10 :)

Acer ICONIA A500 TAB WIFI Only
FW: Tegraowners 6.0 internal ROM
Recovery: touch recovery 2.0b

Asus Google Nexus 7 Wifi
FW: Tegraowners JB-MR2 ROM
++++++++++++
If I did something you liked HIT rep + button (: and Image $Image to BEER FUND
User avatar
thor2002ro
Global moderator / Dev Team
 
Posts: 10042
Joined: 14 Aug 2011, 23:31
Location: 127.0.0.1
Reputation point: 594
Junior OwnerJunior OwnerJunior OwnerJunior OwnerJunior OwnerJunior Owner

Re: TegraOwners a500 Repository

Postby Are G. Bee » 14 Apr 2015, 18:18

thor2002ro » 10 Apr 2015, 16:42 wrote:I cant think of an easy way to get back before... apart from looking at logs and identify the new packages.... or reinstall ubuntu...
but mate and login program are 2 different things... one is not related to the other.... learn how to manipulate apt and you can install many things and versions...



Kudos thor2002ro, you were correct!

It was not MATE at all, but rather updates installed during the "sudo apt-get dist-upgrade" line. After a little digging and some trial and error I was able to find a workaround to resolve the keyboard issue. Instead of running dist-upgrade, I went into aptitude and manually held two packages from updating:

  • lightdm
  • lightdm-gtk-greeter

After they were held I ran the update through aptitude and then continued on to install MATE.


So far so good! :)


I do have another question regarding the mintmenu install. When I attempt to install mintmenu I am stopped with a message stating something like I have unmet dependencies (mint-common) but it is not installable, followed by a message stating that I have held broken packages...Any ideas about how to resolve this? I have tried a few suggestions I found online regarding the broken packages but but nothing resolves this issue.

Thanks again for all your help!
User avatar
Are G. Bee
Junior Owner
 
Posts: 4
Joined: 20 Jan 2012, 17:45
Reputation point: 0
Junior Owner

Re: TegraOwners a500 Repository

Postby thor2002ro » 14 Apr 2015, 18:51

mmm so the issue is with the new lightdm..... mmm I'll see if I get some free time to do more digging into the new lightdm source...
_________________________
Dropbox! So useful for sharing files among multiple computers and ANDROID Phone get 2.30GB storage -> LINK

++++++++++++
Samsung Galaxy Note - Drowned

Samsung Galaxy Note 2 - Sold

Oppo R5s - Sold

LG V10 :)

Acer ICONIA A500 TAB WIFI Only
FW: Tegraowners 6.0 internal ROM
Recovery: touch recovery 2.0b

Asus Google Nexus 7 Wifi
FW: Tegraowners JB-MR2 ROM
++++++++++++
If I did something you liked HIT rep + button (: and Image $Image to BEER FUND
User avatar
thor2002ro
Global moderator / Dev Team
 
Posts: 10042
Joined: 14 Aug 2011, 23:31
Location: 127.0.0.1
Reputation point: 594
Junior OwnerJunior OwnerJunior OwnerJunior OwnerJunior OwnerJunior Owner

Re: TegraOwners a500 Repository

Postby Are G. Bee » 28 Apr 2015, 06:35

Thanks for looking into it, I had a feeling it was something installed during updates so I toughed it out and narrowed it down to those two.

Now on a side note, I am sorry to say that as of 4 nights ago (and after a solid effort to salvage my baby) my Frankenstein'ed A500 has finally passed on... The power button inside had been forced inside in the past and I had to re-solder it a few times already to bring it back to life. Unfortunately this time it was a no-go and I simply cannot power it up anymore, so unless I can find a way to bypass the power button I'm pretty sure my old and most faithful A500 has finally bit the big one... It was a sad day indeed...

and then "that" day ended...

and then I went out and grabbed myself a Samsung Galaxy Tab S 10.5" (SM-T800) to cheer myself up... lol

Now getting to my "real" point... I was happy for a while but after religiously running your ROMs since I got my A500 a few years back I have to admit I am having some serious withdrawals and I would like to attempt to port your Lollipop OmniROM to my Samsung SM-T800 if you'd be willing to help me get started off? If memory serves you had a post up about "Development Opportunities" in the A500 forum and I would like to get some further information so I can attempt to re-thorify my device and gain some of my sanity back!

I would have PM'ed you as suggested in the post but I cannot send PM's because of my new user status. Looking to the future, if all goes well with porting Android then who knows, maybe Ubuntu next..?

If this interests you then please grant me PM privileges so we may discuss it further :)
User avatar
Are G. Bee
Junior Owner
 
Posts: 4
Joined: 20 Jan 2012, 17:45
Reputation point: 0
Junior Owner

Re: TegraOwners a500 Repository

Postby bobby199 » 04 Apr 2017, 22:31

Hi Folks,
I also installed ubuntu 14.04 (hooray and thanks!!!). I never checked onboard virtual keyboard before proceeding to install mate and ended up with similar situation on login, no keystrokes registering with onboard. Anyway, not sure I want to go through this exercise real soon.
Many retries with both CM/Omni (nuther story) to get here and finally after figuring thinks out, have to say your TWRP recovery is indeed slick. Kudos!

I tried to attempt an upgrade prompted by Software Updater "Lubuntu 16.04.2. LTS is now avaialble.." .
Fails with errors getting sources/repositories, doh and reverts back.

I'm running a Class 4 SD, kind of old. Curious how much of an improvement replacing external SD with a Class 10 will make this?

V9 Bootloader
TWRP Recovery
CM12.1 5.1.1 A500/A501 - V7 Final
Lubuntu 14.04
User avatar
bobby199
Junior Owner
 
Posts: 4
Joined: 20 Nov 2015, 19:44
Reputation point: 0
Junior Owner

Re: TegraOwners a500 Repository

Postby bobby199 » 05 Apr 2017, 09:09

Quick update, installed a new SD, faster, much much mu faster ( 2.5 x ). Still on orig 14.04 lubuntu + updated Nvidia driver and new firefox. I'll try the lightdm avoidance above and pull Mate another day.
Getting used to onboard will take a little effort.
I also confirmed internal SD is indeed class 10 with timed copy(s) of the linux tarball to compare.
User avatar
bobby199
Junior Owner
 
Posts: 4
Joined: 20 Nov 2015, 19:44
Reputation point: 0
Junior Owner

Re: TegraOwners a500 Repository

Postby bobby199 » 06 Apr 2017, 01:51

I think there's issues with Onboard, the virt kbd. Mouse functions like right click, double click aren't working for me. Mind you it discovers a USB mouse nicely. Going mouseless appears a challenge. I used a mouse to create desktop icon launchers and they are difficult to launch. Easier to use menu with more taps and fat fingers. :)
I certainly would like to see right click solved.
Anybody observed similar with lubuntu desktop ? you really have to be accurate with double touches to launch.
nit -- abiword sees all upper case :) Caps lock turns on lower case. Oh -oh , still can't type a number in Abiword .
User avatar
bobby199
Junior Owner
 
Posts: 4
Joined: 20 Nov 2015, 19:44
Reputation point: 0
Junior Owner

Re: TegraOwners a500 Repository

Postby bobby199 » 06 Apr 2017, 23:45

Abiword and OnBoard kbd appear to have been fixed with the dist-upgrade. I'd set lightdm and lightdm-gtk-greeter to hold with apt-mark.
User avatar
bobby199
Junior Owner
 
Posts: 4
Joined: 20 Nov 2015, 19:44
Reputation point: 0
Junior Owner

PreviousNext

Return to Acer A500/A501 Linux

Who is online

Users browsing this forum: No registered users and 1 guest

x

#{title}

#{text}