[ROOT] ICS Root for Iconia Tab A500/A501/G100W

Themes, applications and mod's for the Acer A500/A501

Re: [ROOT] ICS Root for Iconia Tab A500/A501/G100W

Postby Nauti » 31 Mar 2016, 17:56

freightyard » 31 Mar 2016, 17:40 wrote:are you sure you
1. have the apx driver installed properly
viewtopic.php?f=8&t=1870&start=30&hilit=apx+driver
2.have the tablet in apx mode - black screen and power button lit
I know it's frustrating when you are new to it :oops: but after awhile you will feel like an expert :doh: and wonder why it was so hard to understand. :ugeek:

Yes, with the help of the guide I mentioned in last post I got ATX mode to work with my computer. If I just start with reset and power button, it's black but when the computer connects I get an Acer logo and the text in the top left saying it's in ATX mode.

I just get different errors whatever method I try. I got this one yesterday and by not buying electronics, I always salvage or get very old ones. Now a lot of newer app version won't work with 4.0.3 but they work fine with my even older phone that is running custom rom. I've been trying for quite a while now and both on my laptop running Ubuntu and my computer running windows 10.
User avatar
Nauti
Junior Owner
 
Posts: 4
Joined: 29 Mar 2016, 20:49
Reputation point: 0
Junior Owner

Re: [ROOT] ICS Root for Iconia Tab A500/A501/G100W

Postby hwally » 26 Dec 2016, 19:32

I keep getting the message: No a500 with usb debugging detected. usb debugging is activated, as well as unknown sources and I've connected the tablet to a computer with windows 7 and another with windows 10. Both detect the tablet. I've even done a factory reset with the same results. I downloaded ICS root 7.2.0. The tablet is running Android 4.0.3. Any ideas? Thank you in advance for any help.
User avatar
hwally
Junior Owner
 
Posts: 3
Joined: 26 Dec 2016, 19:24
Reputation point: 0
Junior Owner

Re: [ROOT] ICS Root for Iconia Tab A500/A501/G100W

Postby freightyard » 26 Dec 2016, 20:04

hwally » 26 Dec 2016, 13:32 wrote:I keep getting the message: No a500 with usb debugging detected. usb debugging is activated, as well as unknown sources and I've connected the tablet to a computer with windows 7 and another with windows 10. Both detect the tablet. I've even done a factory reset with the same results. I downloaded ICS root 7.2.0. The tablet is running Android 4.0.3. Any ideas? Thank you in advance for any help.

could be usb cable
are you plugging into the small one on the tab
won't work on usb full size port
use usbdeview to see if tab is connected properly
User avatar
freightyard
Testers Group
 
Posts: 2676
Joined: 30 Jan 2012, 17:29
Reputation point: 163
Junior OwnerJunior Owner

Re: [ROOT] ICS Root for Iconia Tab A500/A501/G100W

Postby hwally » 26 Dec 2016, 23:34

I checked with usbdeview and it lists Acer iconia tab a500 as connected and safe. Both computers recognize the tablet. I am using the small usb on the tablet. I changed the cable and there was no change.
User avatar
hwally
Junior Owner
 
Posts: 3
Joined: 26 Dec 2016, 19:24
Reputation point: 0
Junior Owner

Re: [ROOT] ICS Root for Iconia Tab A500/A501/G100W

Postby hwally » 27 Dec 2016, 00:52

When I go to device manager under Acer Iconia Tab A500 it states that this device is not configured properly. I try updating the drivers but it's an endless search with no results. also listed is something called MTP, it also isn't configured properly and goes through the endless search for updates.
User avatar
hwally
Junior Owner
 
Posts: 3
Joined: 26 Dec 2016, 19:24
Reputation point: 0
Junior Owner

Re: [ROOT] ICS Root for Iconia Tab A500/A501/G100W

Postby hubmaster080 » 27 Dec 2016, 06:31

hwally » 26 Dec 2016, 17:52 wrote:When I go to device manager under Acer Iconia Tab A500 it states that this device is not configured properly. I try updating the drivers but it's an endless search with no results. also listed is something called MTP, it also isn't configured properly and goes through the endless search for updates.

Sounds like you are in driver HELL.....lol been there.....try doing it in steps....uninstall....reboot...re install....then reboot.....etc
User avatar
hubmaster080
Senior Owner
 
Posts: 194
Joined: 15 Mar 2014, 03:20
Reputation point: 18
Junior Owner

Re: [ROOT] ICS Root for Iconia Tab A500/A501/G100W

Postby niniendowarrior » 03 Jan 2017, 14:02

I've been trying to use the Linux scripts attached here and it isn't working due to syntax issues. I had to chmod +x adb included in the files.

I've attached a corrected root.sh file that fixes some syntax errors in the bash script, but I'm still running into issues with rooter.sh. Overwrite root.sh with the one attached here. This is the current error I get from rooter.sh once adb attempts to execute it.

/data/x-pwn/bin/rooter.sh: cd: line 3: can't cd to /system/xbin
/data/x-pwn/bin/rooter.sh: line 10: syntax error: unexpected end of file (expecting "done")

From what I can tell, the script from rooter.sh checks out just fine so I'm not sure why it's causing issues. Either way, I haven't been able to root the device.

Update:
rooter.sh has been fixed. Apparently it's an issue with dos formatted files (\r\n) which was causing issues when root.sh was executed. Overwrite the rooter.sh on files/rooter.sh

Update 2:
After reboot, I see the Superuser now showing in the app drawer but Root Checker Basic reports that I don't have root access. Hmm... :think:

Update 3:
So, I tested by installing Titanium Backup and superuser asked if I should allow this app root access. I said yes, and Titanium Backup says I have root access. So, I guess that's mission accomplished. :dance:
You do not have the required permissions to view the files attached to this post.
User avatar
niniendowarrior
Helpful Owner
 
Posts: 99
Joined: 31 Dec 2016, 14:35
Reputation point: 0
Junior Owner

Re: [ROOT] ICS Root for Iconia Tab A500/A501/G100W

Postby Neli » 05 Feb 2017, 22:47

The download link not works ? :C
User avatar
Neli
Junior Owner
 
Posts: 1
Joined: 05 Feb 2017, 21:16
Reputation point: 0
Junior Owner

Re: [ROOT] ICS Root for Iconia Tab A500/A501/G100W

Postby wintersommer » 17 Apr 2017, 09:15

The two download links over adv.ly dont work. Can someone please post the file on a service that is more reputable ? Also the host blackthund3r.co.uk is not reachable anymore.
User avatar
wintersommer
Junior Owner
 
Posts: 1
Joined: 17 Apr 2017, 09:10
Reputation point: 0
Junior Owner

Previous

Return to Acer A500/A501 Themes and Apps

Who is online

Users browsing this forum: No registered users and 1 guest

cron
x

#{title}

#{text}